2019-08-29  109 views 发表评论

PHP Warning Module ‘swoole’ already loaded in Unknown on line 0

执行 php bin/swoft 命令或者 执行 PHP --ri swoole 命令时提示此错误:PHP Warning Module 'swoole' already loaded in Unknown on line 0!根据字面理解是swoole扩展已经被加载,说明本次的命令有加载了一次!想到检查PHP配置文件:

vim /etc/php7.1/php.ini

clipboard.png

看到正常加载了一次swoole.so扩展,突然想到我手动给php默认的配置文件配置过,使用

php -i|grep php.ini

 查看配置文件路径

clipboard.png

vim /usr/local/php/etc/php.ini  发现确实有单独加载,把这个直接删除,因为自定义配置都可以

clipboard.png

之后重启php-fpm:service php-fpm restart 咋,再使用刚才的PHP --ri swoole命令不再有警告提示!

给我留言

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: